Note

Every effort has been made to ensure that the information contained in this document was complete and accurate at the time of publishing. Nevertheless, the authors retain the right to modify the information. This customer document describes all the hardware units and functions known at the present time. Descriptions may be included for units which are not present at the customer site. The exact scope of delivery is described in the respective purchase contract.

CE Conformity Declaration

Hereby, VIPA GmbH declares that the products and systems are in compliance with the essential requirements and other relevant provisions.

Conformity is indicated by the CE marking affixed to the product.

Conformity Information

For more information regarding CE marking and Declaration of Conformity (DoC), please contact your local VIPA customer service organization.

Trademarks

VIPA, SLIO, System 100V, System 200V, System 300V, System 300S, System 400V, System 500S and Commander Compact are registered trademarks of VIPA Gesellschaft für Visualisierung und Prozessautomatisierung mbH.

SPEED7 is a registered trademark of profichip GmbH.

SIMATIC, STEP, SINEC, TIA Portal, S7-300 and S7-400 are registered trademarks of Siemens AG.

Microsoft and Windows are registered trademarks of Microsoft Inc., USA.

Portable Document Format (PDF) and Postscript are registered trademarks of Adobe Systems, Inc.

All other trademarks, logos and service or product marks specified herein are owned by their respective companies.

Information product support

Contact your local VIPA Customer Service Organization representative if you wish to report errors or questions regarding the contents of this document. If you are unable to locate a customer service center, contact VIPA as follows:

VIPA GmbH, Ohmstraße 4, 91074 Herzogenaurach, Germany

Telefax: +49 9132 744 1204
EMail: documentation@vipa.de

Technical support

Contact your local VIPA Customer Service Organization representative if you encounter problems with the product or have questions regarding the product. If you are unable to locate a customer service center, contact VIPA as follows:

VIPA GmbH, Ohmstraße 4, 91074 Herzogenaurach, Germany

Telephone: +49 9132 744 1150 (Hotline)
EMail: support@vipa.de
Contents

Content ................................................................................................................ i
Introduction ......................................................................................................... 1
    Basics ........................................................................................................... 1
    Function specification ............................................................................. 3
Installation ........................................................................................................... 6
    Requirements ............................................................................................ 6
    Setup .......................................................................................................... 7
    Security policies ....................................................................................... 8
    User- and group permissions for Component Services (only Server PC) .. 9
    DCOM configuration .............................................................................. 15
    Licensing .................................................................................................. 18
    Firewall settings for Windows XP, Server 2003 and Vista .................... 21
    Firewall settings for Windows Server 2008 and Windows 7 ................. 23
OPC-editor ........................................................................................................ 30
    Directory .................................................................................................... 30
    Behavior when saving ............................................................................. 30
    File menu .................................................................................................. 31
    Edit menu .................................................................................................. 33
    Tools menu ................................................................................................ 35
    Help menu ................................................................................................. 41
Configuration interface ................................................................................... 43
    Project view .............................................................................................. 43
    Detailed view ............................................................................................. 44
    OPC-project ............................................................................................. 44
    MPI-network ............................................................................................. 47
    MPI-controller ......................................................................................... 48
    Read/Write over TCP/IP network ......................................................... 50
    Read/Write over TCP/IP controller ....................................................... 50
    S7-PG over ISO on TCP/IP ................................................................. 55
    ISO on TCP/IP controller ...................................................................... 55
    List of tags ................................................................................................. 58
    Sorting the tags on the display ............................................................. 59
    Deleting tags ............................................................................................... 59
    Using MS Excel to configure the tag list .............................................. 59
    Displaying the online value of a tag ...................................................... 60
Example of an OPC-project ............................................................................ 62
    Define a new project and a network...................................................... 62
    Adding a controller ................................................................................... 63
    OPC-Server reconfiguration ................................................................. 65
Appendix ........................................................................................................... 68
    The Syntax of the link ............................................................................. 68
Index ............................................................................................................... 73
Introduction

Basics

General

The OPC-Server is based on the international standard that was defined to provide OPC client access to PLC controllers of different manufacturers.

The current version of the OPC-Server supports TCP/IP networks connected by means of industry standard network adapters as well as MPI networks that are connected to the computer via one or more COM-ports and an MPI-serial converter.

The OPC-Server supports the Slot-CPU when this is installed in the computer. This device also employs the MPI-or TCP-protocol. Every Slot-CPU creates a port in the PC and therefore represents a separate MPI- or TCP-network. Such an network can only support a single controller - the Slot-CPU.

You can configure any number of MPI-networks. The number of networks is limited by the available number of COM-ports.

You may also configure as many TCP/IP-networks as you require. These are only limited by the maximum number of network adapters that you can install in your PC.

Order data

<table>
<thead>
<tr>
<th>Order number</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>SW110A1LA</td>
<td>OPC-Server MPI driver, single licence</td>
</tr>
<tr>
<td>SW110A2LA</td>
<td>OPC-Server RFC1006 driver, single licence</td>
</tr>
<tr>
<td>SW110A3LA</td>
<td>OPC-Server TCP/IP driver (Read/Write), single licence</td>
</tr>
</tbody>
</table>
Schematic diagram of the MPI-network configuration

Schematic diagram of the TCP/IP-network configuration
Function specification

Overview

The OPC setup contains an OPC-Server, a configuration environment providing access to all the necessary settings, a driver for the MPI protocol via COM-Port, a TCP/IP driver for the Read/Write protocol and a driver for the S7-PU protocol via ISO on TCP/IP.

When the configuration environment has been installed, the OPC editor (of the configuration environment) is available for the configuration of MPI and/or TCP/IP networks. The networks are connected to stations that must be configured as well. Here you should define clear and informative names to the stations, e.g. "MPI-network packing" or for PLCs you might use "Conveyor 1" etc.

In the OPC-Server you will define a set of variables that are allocated to the respective data in the PLC. In the OPC-environment these variables are referred to as "tag".

You have two options to manipulate tags:

Static tags (symbolic links)

You can use the OPC-editor to define tags, assign informative names to these tags and link the tags to the data points in PLCs. Once the tags have been defined you must re-configure the OPC-Server. The OPC-Server reads the configuration data and offers the tags to the different OPC clients with the symbolic names you have assigned.

The OPC client, which can consist of visualization, can select the defined tags directly by means of the OPC-browser.

In this document we refer to this type of link as "static tags" or as "symbolic link". When the OPC-Server starts it recognizes all the static tags as well as the access rights that you have previously assigned, e.g. read only or read write for a specific tag.

The following syntax applies:

**PLC name/symbolic name**

Example:

You want to create a link to the tag "Automatic" in PLC "Conveyor1":

**Conveyor1/Automatic**
Dynamic tags (absolute links)

You also have the option to link directly from your visualization to the respective data of the PLC if you do not want to pre-define the tags. This type of link is referred to as "dynamic tags" in this document.

The following syntax applies:

**PLC name/physical data point**

**Example:**

You want to create a link to "Flag 1.0" in PLC "Conveyor1":

**Conveyor1/MX1.0**

If an OPC client, for example a visualization system, should attempt to access the OPC-Server to link to a data point the OPC client will always transfer the name of the data point to the OPC-Server. This operation does not depend on whether you have selected the variable from the OPC-Server by means of the browser or whether you have specified the name directly in the visualization system.
Example

You use the OPC-browser to select a tag in the visualization. This tag is named "Conveyor1/operating hours'.

The OPC client sends a request to the OPC-Server: Transfer "Conveyor1/operating hours" as a character string.

The OPC-Server checks whether a tag named "operating time counter" has been defined for PLC "Conveyor1".

If the required tag exists the OPC-Server will read the value of the tag from the PLC by means of a cyclic operation via the respective network and transfer this to the OPC client. The client defines the cycle time.

The OPC client notifies the OPC-Server when the client no longer requires the data for "Conveyor1/operating hours". At this time the OPC-Server stops the read cycle from the PLC.

However, if the OPC-Server can not locate the tag it checks whether the name corresponds with a physical link, e.g. MB0. This does not apply to the current example. The OPC-Server returns an error message to the OPC client.

Enter the name of the chosen tag manually instead of using the browser to select tags from the list of configured tags that is presented by the visualization. You can enter names like "Conveyor1/Operating hours" or "Conveyor1/MX1.0".

When the OPC-Server receives this request the process is the same as in the previous example. First the OPC-Server will test whether a configured tag with the specific name is available. This example does not contain a tag of this name.

Next the OPC-Server will test whether the name results in a valid link. In this case this is true. The OPC-Server will now dynamically define a tag with the name "Conveyor1/MX1.0" in its addressing space. Similar to the procedure that is used for static tags it will read the value from the PLC and transfer this to the OPC client in a cycle.

You may decide that you want to prevent dynamic access to the data of a PLC from external visualizations. For this purpose a parameter is available for every PLC. In the OPC-editor you can specify the method that the OPC-Server should use to access the dynamic link to each PLC. Here you can inhibit dynamic links (off), you can enable the link for "read only" or you can enable the link for "read write" operations.

You can mix static and dynamic links at will across PLC's and also within a PLC.

Please remember that you must have defined the networks and PLC's by means of the OPC-editor at least once to ensure that the drivers have registered working-data.
**Installation**

**Requirements**

**Operating system**

The operation of the OPC-Server was tested on the following operating systems:

- Windows XP Pro with SP3 32 bit
- Windows XP Pro with SP3 64 bit
- Windows Vista Ultimate with SP1* 32 bit
- Windows Vista Ultimate with SP1* 64 bit
- Windows Server 2003 R2 with SP2 32 bit
- Windows Server 2003 R2 with SP2 64 bit
- Windows Server 2008 R2 64 bit
- Windows 7 Ultimate 32 bit
- Windows 7 Ultimate 64 bit

*) This operating system is not recommended!

**Trademark**

Windows® is a registered trademark of Microsoft Corp.
S5® and S7® are registered trademarks of Siemens AG.

Any other trademarks referred to in the text are the trademarks of the respective owner and we acknowledge their registration.

**Important!**

The following settings are only required if a remote access to the VIPA OPC-Server may take place (client and server on different computers).
Setup

Important!
You can only start the setup if you have logged in to the computer as the system administrator.

Procedure

The OPC-Server is supplied on a CD. The CD contains a setup program. You must start the program **Setup.exe** to start the installation.

Setup can be started in English or in German. Please select the language of your choice. The selected language does not affect the execution of the program.

Choose the path where Setup should be installed. You can simply accept the path suggested by Setup. Please note that this path is also used to save the current project with the current configuration data.

Next, Setup will offer you the following installation options:

- **OPC-Server**
- **OPC-Editor**

OPC-Server is the server itself. If you select this option the OPC-editor is also installed automatically.

OPC-editor is the configuration environment. You can select to install this separately on a computer to be able to create configurations locally. You must transfer the generated configuration data to the target computer that is running the OPC-Server by means of the Windows file manager or the Windows Explorer.

The next dialogue box that is displayed by Setup provides you with the option to change the default names for the program group. We recommend that you accept the default.

The next dialog box displayed by Setup shows a summary of your selections and entries. If at this point you click the button [Next] the programs you have selected will be installed.

Once the programs have been installed the computer may have to be re-booted. This depends on your selection of installation options.

Important!
The DCOM properties are read during setup.

When you have installed the OPC-Server on a computer you can define the parameters for the DCOM configuration. For this purpose you start the OPC-editor tool. The tool guides you through the DCOM-configuration. You can also refer to the chapter **The DCOM configuration** for details.
Security policies

**Important!**
These settings are only required starting with Windows XP.

**Procedure**
Open the menu **Local Security Policy** via **Start > Administrative Tools > Control Panel**.

Select the **Security Options**.

Change the settings for following points:

<table>
<thead>
<tr>
<th>Setting name</th>
<th>Settings</th>
</tr>
</thead>
<tbody>
<tr>
<td>Network access: Let Everyone permissions apply to anonymous users</td>
<td>Enabled</td>
</tr>
<tr>
<td>Network access: Sharing and security model for local accounts</td>
<td>Classic - local users authenticate as themselves</td>
</tr>
</tbody>
</table>

Close the window **Local Security Policy**.
User and group permissions for Component Services (only server PC)

**Important!**
These settings are only required starting with Windows XP.

**Procedure**

Open the menu **Component Services** via **Start > Run > dcomcnfg**.

With the right mouse button click at the entry **My Computer** and select **Properties**.
User and group permissions

Select the register **COM Security** to preset the user and group permissions.

![COM Security](image-url)
Access Permissions: Click at **Access Permissions** on [Edit Limits…].
Select at **group or user names**: 
- Administrators
- ANONYMOUS
- User
- INTERACTIVE
- Everyone
- NETWORK
- SYSTEM
and save these with [Add…].
Allow "Local Access" and "Remote Access" for these user and group names and confirm with [OK].
Access Permissions: Click at **Access Permissions** on [Edit Default…].
[Edit Default…]

Select at **Group or user names**:

- Administrators
- ANONYMOUS
- Users
- INTERACTIVE
- Everyone
- NETWORK
- SYSTEM

and save this with [Add…].

Allow “Local Access” and “Remote Access” for these user and group names and confirm with [OK].
Launch and Activation Permissions

Click at **Launch and Activation Permissions** on [Edit Limits…].

Select at **Group or user names**:

- Administrators
- ANONYMOUS
- Users
- INTERACTIVE
- Everyone
- NETWORK
- SYSTEM

and save these with [Add…].

Allow "Locale Launch", "Remote Launch", "Local Activation" and "Remote Activation" for these user and group names and confirm with [OK].
Launch and Activation Permissions

Click at **Launch and Activation Permissions** on [Edit Default…].

Select at **Group or user names:**

- Administrators
- ANONYMOUS
- Users
- INTERAKTIV
- Everyone
- NETWORK
- SYSTEM

and save these with [Add…].

Allow "Local Launch", "Remote Launch", "Local Activation" and "Remote Activation" for these user and group names and confirm with [OK].
The DCOM configuration

Overview
The OPC-technology is based on the DCOM-technology of Microsoft. DCOM provides the background required for a client to connect to an OPC-Server via a network. Any client that should connect to an OPC-Server by means of DCOM must have been assigned the respective rights. You must configure the rights of the client by means of the tool DCOMCNFG.EXE of Microsoft. The rights must be configured on the specific computer where the OPC-Server was installed as well as on the computer where the OPC client is executed.

The DCOM-configuration on the server PC (i.e. the computer executing the OPC-Server) and the client PCs (i.e. the computers that execute the OPC clients) are identical.

Procedure
The following chapter describes the DCOM-configuration that is possible for the server and the client computers.

Here we will only describe those settings that differ from the standard Windows settings.

Start the Microsoft tool DCOMCNFG.exe by means of Start > Run on the taskbar.

As an alternative you can also use the menu item Tools of the OPC-editor where you can click at DCOM configuration.

The following dialog box is displayed:

With the right mouse button click at the entry My Computer and select Properties.
Here you select the **Default Properties** tab.
In this tab you configure the Combo-boxes as shown below:
The Combo-Box with the heading **Default Authentication Level** controls the level on which the client must be authenticated. Here the only entries making sense are "None" and "Connect". When the server and the client PC are not located in a common domain you must select "None".

Where server computer and the clients are located in the same domain you can select the entry "Connect" to increase the level of security.

Even if all computers are located in the same domain we recommend that you select "None" during the commissioning phase.

The Combo-Box for **Default Impersonation Level** defines the method, that the OPC-Server can apply to the name of the client. Should it identify the client or should it remain anonymous, or do you wish to allow the OPC-Server to act instead of the OPC client, e.g. to access operating system function calls in the name of the client. We recommend that you use setting "Identify".

No additional DCOM-dialog settings are required for the general operation of the OPC-Server. The OPC-Server can use the standard settings without any problems.

**Attention!**

You must remember that these settings are required on the server and on each separate client computer.

Additional information on DCOM and the respective configuration is available from the Microsoft Homepage on the Internet as well as from the relevant technical literature.
Licensing

Overview
The consignment of the OPC-Server includes protocol driver files that are for test purposes free available for 24 hours. After 24 hours, the shareware mode is locked automatically.

To release the drivers again you have to purchase a licence at VIPA. For the licence key refers to the hardware, the activation for the concerning PC happens online via a web site.

Sending the hardware ID and licence key, you receive an email with the activator key which you use to release the according protocol driver file via the OPCLicence tool.

Registration
Approach for the registration:
You receive a licence key per email from your sales partner. Start the program **OPCLicence** via **Start > Programs > ... > OPCLicence**.

**Important!**
With **Windows 7**, **Windows Vista** and **Windows Server 2008** you have to start **OPCLicence** with extended administrator rights! For this click with the right mouse button on **OPCLicense** and select "Run as administrator". Confirm the security query with [Yes] and enter the administrator password if required.

The following dialog window appears:

The hardware ID is a sequence of numbers that is generated depending on the hardware installation of your PC. This number sequence is required for the online registration.

Choose the web site: [http://www.key-reg.com/](http://www.key-reg.com/). The following input dialog appears:
Enter your personal data. Don’t forget the email address.

Enter the hardware ID and your licence key and click at [Submit]. You receive the activator key immediately per email.

Switch to the dialog window of **OPCLicence** and enter the activator key for the according protocol driver. Confirm with [register].

With a valid activator key, the registration property changes from "unregistered" to "registered".

Now the registration is finished.

**ORDER FORM**

If you want to purchase more software licences, you may order them with the order form under [ORDER FORM]. Print and fill the form and send it per fax to your sales partner. He will contact you soon.

**Reconfiguration**

To send the licence key to the OPC-Server, you have to reconfigure it.
Firewall settings for Windows XP, Server 2003 and Vista

Important!
These settings are required for:
- Windows XP
- Windows Vista
- Windows Server 2003

Procedure
- Open the menu Windows-Firewall.
  at Windows XP via Start > Control panel > Security center
  at Windows Vista via Start > Control panel > Security
  at Windows Server 2003 via Start > Control panel

- Go to the register Exeptions.

- Select the following points via the button [Program...]:
  OpcEnum.exe (OpcEnum.exe)
    with 32 bit at C:\WINDOWS\System32
    with 64 bit at C:\WINDOWS\SysWOW64
  OPC Toolbox Demo Client (SOClient.exe), if available on client PC.
  VOPCSRV.exe (VOPCSRV.exe) = VIPA-OPC-Server
    at 32 bit at C:\Program Files\Vipa GmbH\OPC-Server
    at 64 bit at C:\Program Files (x86)\Vipa GmbH\OPC-Server

Important!
Adding VOPCSRV.exe is only required at server PCs!
Then select the point "File and Printer Sharing" in the overview Programs and Services.

![Windows Firewall](image)

Carry out the following points via the button [Add Port]:

![Edit a Port](image)

Confirm with [OK].
Firewall settings for Windows Server 2008 and Windows 7

**Important!**
This settings are required for:
- Windows Server 2008
- Windows 7

### Procedure
- Open the menu Windows-Firewall via Start > Control Panel > System and Security.

- Select "Allow a program or feature through Windows Firewall".

- Select the following points via the button [Allow another program]:
  - OpcEnum.exe (OpcEnum.exe)
    - with 32 bit at: C:\WINDOWS\System32
    - with 64 bit at: C:\WINDOWS\SysWOW64
  - OPC Toolbox Demo Client (SOClient.exe), if available on client PC.
  - VOPCSRV.exe at C:\Program Files (x86)\Vipa GmbH\OPC-Server

**Important!**
Adding VOPCSRV.exe is only required on the server PCs!

Then select the point "File and Printer Sharing" in the overview Allowed programs and features
Change into the menu Advanced Settings.
Select the point "Inbound Rules" and confirm the button [New Rule...].
The **New Inbound Rule Wizard** is opened. Select the option "Port" and click at [Next].
Select in the next window "TCP" and enter the Port "135" at the option "Specific local ports". 
Confirm with [Next].
In the next window select "Allow the connections" and click at [Next].
In the next window select all options and click at [Next].
In the last window enter at Name "DCOM" and click at [Finish].

Make the same settings for the point "Outbound Rules".
OPC-editor

Directory

Start

The OPC-editor is located in the directory 
C:\Program Files\OPC.

The name of the program is OPCParam.EXE. The setup procedure 
generates a link with the name “OPC Editor” in the program group OPC.

The menu item File > End terminates the application. 
This application can not be started more than once.

Important!

With Windows 7, Windows Vista and Windows Server 2008 you 
have to start the OPC-editor with extended administrator rights! For this 
click with the right mouse button on the OPC-editor and select “Run as 
administrator”. Confirm the security query with [Yes] and enter the 
administrator password if required.

Behavior when saving

Manual save

Any modifications to a loaded OPC-project are only saved at the 
request of the user (i.e. not automatically). Before issuing any actions 
requiring that the current project be saved (e.g. terminating the 
application) the application will ask for confirmation whether the current 
OPC-project should be saved or whether the modifications can be 
discarded.

The entire OPC-project will be saved.
File menu

Overview

The file menu contains the following items:

- Project new
- Project open
- Project save
- Project save as
- Load recently processed projects
- End

Project new

Creates a new OPC-project. When an OPC-project has already been loaded and this has been modified you will be prompted whether you wish to save the current project or not.

Project open

Opens a stored OPC-project. If you have previously loaded and modified an OPC-project you will be prompted to specify whether the current project should be saved or not.

The dialog defaults to the file "VOPCSRV.INI" in the directory "INI" that is located below the application directory C:\Programme\OPC.

In order that the root file of an OPC-project can be used with the OPC-Server it must have the name VOPCSRV.INI.
**Project save**  
Saves the loaded project in the same directory from where it was originally loaded.

Since the path has not yet been defined when a newly created OPC-project is saved for the first time a message is displayed requesting that you use the menu-item *Project save as*.

**Project save as**  
You would use *Project save as* to save a project in another directory (or if a project is saved for the first time).

The dialog requires that you select a directory where the files of the OPC-projects will be saved. You can select both, a directory on a local drive as well as a network drive.

**Load recently processed projects**  
The four most recently processed projects are available from a list in the *file* menu from where they can be loaded directly.

**End**  
Terminates the application. When an OPC-project has been loaded that has been modified you will be prompted to specify whether you wish to save the current project before termination.
Edit menu

Overview
The Edit menu is only active when a project was loaded or when it has been created. This menu contains the following items:

- Add a network
- Delete a network
- Add a PLC
- Delete a PLC
- Rename

Add a network
Every OPC-project can include a number of networks. You can add another network to a project by means of Add a network.

The dialog requires that you enter a name for the network and that you specify the respective communication protocol.

Note!
The names that are assigned to networks must be unique within the project. The OPC-editor displays a message when you enter a name for a network that has already been used elsewhere. It will also request that you enter a different name.
Special characters (mutated vowels etc.) are not allowed for network names and will be ignored in the entered network names.

Delete a network
This menu item removes the selected network from the OPC-project. It also removes all the PLC’s that were defined for the network from the project. However, the respective configuration files are not deleted automatically. These will remain in the subdirectory \INI.
Add a PLC

A network within an OPC-project can consist of a number of PLC's. You can add another PLC to the selected network by means of this menu item.

![Create PLC dialog](image)

The respective dialog requests that you enter a name for the PLC.

**Note!**
The names that are assigned to PLC's must be unique within the project. The OPC-editor displays a message when you enter a name for a PLC that has already been used elsewhere. It will also request that you enter a different name.

Special characters (mutated vowels etc.) are not allowed for PLC names and will be ignored in the entered network names.

Delete a PLC

This menu item removes the selected PLC from the OPC-project.

Rename

You can change the name of a network or a PLC by means of this menu item. The name you enter here is subject to the same restrictions as mentioned above for the creation of network and PLC names.

**Attention!**
You must not change the name of a PLC once an OPC client has been linked to the tags of the PLC since the OPC-Server can otherwise not locate the PLC.
Tools menu

Overview  The tools menu provides access to the following menu items:

- Read error display
- Write error display
- Language
- Font size
- DCOM configuration
- Log file display
- User administration
- Configuration of services
- Display eventlog
- OPC-Server reconfiguration
- Settle Project Directory
- Options

Read error display  When you load an OPC-project by means of Project open the file VOPCSRV.INI as well as all the files depending on the OPC-project are loaded.

Any errors that could have occurred during this process are collected in this list and can be displayed when the load operation has been completed.
Certain details are displayed for every error:

**Type**

Describes in which portion of the OPC-projects the error was detected (in the root file, in a network, in a PLC, in an OPC-tag).

**File**

Specifies which file caused the read error. It is possible to locate the error by means of the file name.

**Text**

Contains a description of the error. This could, for instance, inform you that an expected parameter could not be read at all (i.e. it does not exist) or that the value that was read for this parameter exceeds the limits that apply to the parameter.

**Note!**

When you click in the line of an error by means of the mouse the respective description is displayed at the bottom of the box. In this manner it is possible to display lengthy error messages.

**Write error display**

When you save an OPC-project the file VOPCSRV.INI as well as all the files related to the OPC-projects are saved. Any errors that are detected during this process are collected in a list, which is displayed when the save operation has completed. The structure of this error list is the same as the list that is displayed for read errors.

**Language selection**

The OPC-editor can be set to operate in one of many languages. The text entries for the different languages are contained in the file OPCParam.DLL. Select the required language from the list of languages offered. This modification is effective immediately. The selection is saved when the OPC-editor is terminated. When the OPC-editor is re-started the language that was selected most recently will be used.

**Font size**

Here you can select from a list of font sizes. This modification is effective immediately. The selection is saved when the OPC-editor is terminated. When the OPC-editor is re-started the font size that was selected most recently will be used.
**DCOM configuration**

Certain DCOM settings are possible for the proper operation of OPC. This menu item starts the DCOM-configuration application of Windows. You can read a description of the DCOM configuration in the DCOM-configuration chapter in the installation section.

**Log file display**

The OPC-Server maintains certain log files where the errors that have been detected are recorded. These files are located in the subdirectory \LOG in C:\Program Files\OPC. The system maintains two log files in shift register fashion. LOG1.TXT contains the current log file data. When the size of LOG1.TXT exceeds the predefined value it is renamed as LOG2.TXT replacing any existing LOG2.TXT file.

You can select which of the two files you wish to display.

This starts the windows "notepad" loading and displaying the selected file.

**User administration**

This menu item opens the Windows-NT user administration dialog. The dialog that is displayed depends on the version of the operating system (NT 4.0, W2000 or WXP).

**Configuration of services**

This menu item provides access to Windows services.

**Display eventlog**

This menu item opens the Windows eventlog.
OPC-Server reconfiguration

When you have modified and saved the data of an OPC-project you must instruct the OPC-Server to read and process the modified files. For this purpose you must terminate and re-start the OPC-Server. This sequence of operations can be automated.

Click at the [Reconfigure] button to start the operation.

During the reconfiguration and when this process has been completed the respective messages are entered into the list that indicates whether the operation was successful or whether errors were detected together with the respective type.

**Note!**
This menu can only be used to reconfigure locally installed OPC-Servers. When the OPC-Server is executed on another computer on the network the reconfiguration must be carried out at this computer.
Settle project directory

If you add networks and stations while projecting and you delete them again, data files not used anymore will be "collected" in directory `\ini` below the installation directory.

Always when deleting a network or a control out of the OPC project, the proper data file remains. This is intended as that gives you the option to restore data which were deleted by mistake.

If you would like to clear all data no longer required, the following function is available herefore:

The green hook indicates that the respective data file belongs to the project. You should not delete these data files. The red cross indicates that the respective data file does not belong to the project anymore. These data files can be deleted.

In the first column, for each data file a control bar is automatically indicated - all data files for deletion do have a hook as default.

Click at the button [Delete Files] and all data files which are marked in the first column are being deleted.

If you don't want to delete all data not longer required, you have to deselect all respective data files in the first column before clicking the button [Delete Files].
Options

The option-dialog enables you to make individual adjustments of the OPC-editor security checks.

After having made your selection in the tool bar, the following option box is being opened:

![Options dialog]

Make your choice and secure your adjustments by clicking onto the button [OK]. These adjustments are being stored so that they are still valid when start this program again.
Help menu

Overview
The help menu provides access to the following menu items:

- Help
- About
- Display OS-version
- Display file information

Help
Opens that document as PDF file.
You must have installed on the PC the Adobe reader at least in the version 4.0.

About
Opens a window containing contact details.
This window indicates the version of the product of the OPC-Server.

Display OS-version
For diagnostic purposes you must know which operating system is installed on the server where the OPC-editor is being executed.
This menu item starts the Windows diagnostics. The displays differ depending on the version of the operating system.
However, in each case the operating system version as well as the service-pack level is displayed.
Display file information

For diagnostic purposes it is important that the exact versions of the different OPC-Server files be known in addition to details of the operating system version. This menu item opens a window that displays information on data version of the OPC-Server.

The list contains all the files that are located in the directory of the OPC-editor (i.e. normally all the files in the directory C:\Program Files\OPC). The list ends with certain special files of the Windows\System32-directory.

The list contains the names, date of last change as well as the version of the file.

You can transfer the displayed information into a file (e.g. to use it in an e-mail or in a FAX).

The file "VERSIONS.TXT" is saved in the directory "\LOG" located in C:\Program Files\OPC.

You can close the windows by clicking on the button [Close].
Configuration interface

Project view

OPC-editor

The left panel shows a hierarchical representation of the OPC-project (tree-view). The different networks and the respective PLCs are arranged below the file VOPCSRV.INI that represents the root of the tree.

Select an entry in the tree view to display the respective details.

The right panel displays the details of the selected objects. The display changes in accordance with the type of the selected object (OPC-project file, network, PLC).

You can display the context menu by right-clicking an entry in the tree-view with the mouse. The context menu displays a menu of actions that are accepted for the selected object (e.g. "Delete" or "Rename").

The functions that are initiated via the context menu are identical to those that are available from the Edit menu that were previously described.
Detailed view

OPC-project

Select the OPC-project file (at the root of the hierarchical panel) in the project view to display the respective data.

OPC-project file

The table in the right-hand panel contains all possible settings:

File name

This entry returns the file name where the data is saved. This entry can not be changed since the file name of the OPC-project is preset to VOPCSRV.INI so that the OPC-Server can process the data.

Log file size

You can use this parameter to specify the maximum size of the log file (LOG1.TXT and/or LOG2.TXT). The size is specified in kilobyte.
Case sensitivity at tags

This option chooses if the OPC-Server should recognize small and capital letters at tags or not.

If you want the OPC-Server to use case sensitivity, enter here a "1", otherwise a "0".

The presetting for a new project is "0".

Example for case sensitivity on:
You've created a new control "loader". Now you may create a tag "failure" and a tag "FAILURE". The OPC-Server takes this as two different tags.
But if you turned off the case sensitivity, the OPC editor doesn't allow you to create a second tag "FAILURE" when "failure" already exists.

If you turn off the case sensitivity, the setting "save tags in capitals " gets relevant. If this is enabled, all letters of a tag are switched to capital letters otherwise they remain as entered.

Note!
This option has no influence on the names of the entered control labels.
Used separator

Enter here the separator that the OPS server will send to the OPC client.

Example:
You send the following combination to the OPC client:

"loader!failure"

Using the default setting, the OPC-Server sends this (after proofing) back to the OPC client as:

"loader/failure"

If you want to use the exclamation mark, you may parameterize this here.

You may parameterize the following signs as separator:

!§$%&/()=?+~^°'#;:-_

Please regard that the set separator must not be part of a control label or a tag name.

The presetting for a new project is the slash /.

Store tags in capitals

If the option "regard case sensitivity at tags" is turned off you may here use the option "store tags in capitals" to choose how the entered tag names are stored.

If you set the option to value "1" all characters of the entered tag names are stored in capital letters.

Leave the option setting at value "0" to store the tag names exactly like you’ve entered them.

Note!
This option has no influence on the names of the entered control labels.
**MPI-network**

Select an MPI-network in the project view to display the respective data.

**File name**

This entry specifies the file name for the file where the data is saved. This name can not be changed. The file name is derived from the name of the network in the project view.

**Baudrate**

This parameter determines the communication speed for the serial interface. You can select the settings from a list. To display the list of parameters you can double click the field with the mouse or you can press a key on the keyboard. The baud rate specified in this field does not refer to the MPI-network itself but to the data transfer via the serial interface of the PC to the MPI-converter that connects the serial interface to the CPU-interface.

**COM-Port**

This parameter specifies the COM-port that will be used to communicate with the OPC-Server.

**Highest MPI-slave number**

This parameter specifies the highest MPI-slave number that is acceptable on this network.

**Local MPI-slave number**

This parameter determines the MPI-slave number of the PC.

**Cycle time**

This parameter specifies the cycle time that is used by the OPC-Server to communicate with the PLC that is located on the next lower level. The default value is 10ms.

**Simultaneous MPI connections**

Default: 4

This value tells how many MPI connections the OPC-Server may use at one time. The PLC-Tool needs one MPI connection that you must reserve.

Set then the value 3.
MPI-controller

Select an MPI-controller of an MPI-network to display the data associated with it.

File name

This entry specifies the file name of the file where the parameters of the controller are saved. This name cannot be changed. The file name is derived from the name of the controller in the project view.

MPI-slave number

This parameter determines the MPI-slave number of the controller. You must make sure that the MPI-slave number of every controller is unique on the bus.

Dynamic tags

This parameter determines whether the controller will support dynamically generated tags or if it should only use the pre-configured tags.

This field is a selection field. You can open the list by pressing a key on the keyboard.

Static tags are tags that you have defined by means of the OPC-editor. You can select certain of these OPC-tags on the OPC client by means of the browser.

The tags that you have defined directly by means of the OPC client are referred to as dynamic tags. The OPC-Server generates the tag dynamically if you do not select existing tags by means of the browser of the OPC client but decide to enter the name of the controller and the link (separated by a slash) directly into the input field.

Example

You have entered "Heater/MW0" directly into an OPC client. The OPC-Server will first check whether a static tag by the name "MW0" was previously defined in the controller "Heater". If it cannot locate a tag named "MW0" the OPC-Server checks whether the term "MW0" represents a valid link to a CPU. In this example this is true. The OPC-Server will now dynamically generate a tag by the name of "Heater/MW0" and that is linked to "MW0" in the PLC referred to as "Heater". The data type results from the syntax "word", i.e. unsigned 16-bit number in this case. The switch "DynamicTags" determines whether the dynamically generated tag is "read only" or "read write".
**Simulation**

You can instruct OPC-Server to simulate this PLC by means of the switch "simulation". This can assist you when you do not have access to a PLC for test purposes, for example to test your visualization. This is a selection field. Press any key to open the selection list. You can define an initial value for each tag that is used by the simulation.

When an OPC client accesses a tag that is located in a simulated PLC then the initial value is returned that was configured for the tag when the project was started. If the OPC client writes a value into the tag then the OPC-Server saves the new value and returns this to the client when this reads the value again. If the client is terminated and started the OPC-Server will again return the initial value.

If you should start several OPC clients and link them to the same tag then all OPC clients will receive the same value for that tag, exactly in the same manner as if the PLC was not being simulated. Every OPC client has the permission to write and all OPC clients receive the entered value as the value that is read. The OPC-Server stores the last value that was written as long as an OPC client requests the tag.

You can only configure an initial value for the simulation for static tags. If the OPC client should be using dynamic tags then the value is set to 0 for numeric tags and to "x" for strings.

If you have configured static tags that overlap then this does not have any effect in the simulation mode.

**Example**

You are configuring the tags:

TestSPS/Wert1 MB10
TestSPS/Wert2 MW10

When an OPC client writes a value into MB10 only the OPC clients for the tag "Wert1" are notified of the change in the value and not those for the tag "Wert2".
Read/Write over TCP/IP network

Select Read/Write over TCP/IP network in the project view to display the respective data.

File name
This entry specifies the file name of the file where the data is saved. This name can not be changed. The file name is derived from the name of the network in the project view.

Local IP-address
If your computer is equipped with more than one network adapter then you must enter the IP-address of the adapter to which this Read/Write-Network applies in this location.
If your computer is equipped with a single network adapter you can enter the IP-address 0.0.0.0. If you specify this address the first network adapter that is detected will be used automatically.

Read/Write over TCP/IP controller

Select the controller of a R/W over TCP/IP network to display the respective data.

File name
This entry specifies the file name of the file where the parameters of the controller are saved. This name can not be changed. The file name is derived from the name of the controller in the project view.

Type of controller
This parameter specifies the CPU-family of the connected CPU. This is required, for example, when addresses must be calculated in data blocks since the addressing in an Siemens S5-system occurs by word and in the addressing an Siemens S7-system is based on bytes. This entry is also required for the conversion of floating point numbers. Siemens S7-systems employ the ANSI format that is commonly used by PC-based systems while the Siemens S5-system employs a Siemens-specific format to represent numbers. This must be converted to the PC-format.
Make your choice from the available list of parameters.
Local port in read mode

The Read/Write protocol via TCP/IP requires a separate TCP/IP connection for reading and writing. A TCP/IP-connection is defined by the local TCP/IP-address and a port number as well as the remote TCP/IP-address and port number.

Here you can configure the port number for the read-connection. In this case it is essential that you make sure that port number are unique.

The definition of a port number is optional. We recommend that you do not use port numbers other than 0. When you specify a port number that is 0 the OPC-Server will determine an unused port number automatically and use it for the communication link. In this manner you can avoid a duplication of port numbers.

Local port in write mode

This is subject to the same conditions as for local port in read mode.

Remote IP-address

Here you must specify the IP-address of the CPU. Make sure that the IP-address of the CPU and the IP-address of the PC are located in the same network (network-mask) when you assign addresses.

Alternatively here you may enter a name. The OPC-Server supports name resolution like e.g. MyPLC.DynDNS.org.

Remote port read

Here you must configure the port-number for the read-connection. You will use this port-number to configure a job (fetch) on the CP.

You can not specify a port address of 0 in this field.

Make sure that port number of the CP is unique; i.e. avoid duplication on the CP.

Remote port write

Here you must configure the port-number for the write-connection. You will use this port-number to configure a write job on the CP.

You can not specify a port address of 0 in this field.

Make sure that port number of the CP is unique; i.e. avoid duplication on the CP.
Dynamic tags

This parameter determines whether the controller will support dynamic tags or whether it will only use preset tags.

This is a selection field. Press a key on the keyboard to open a list for the selection.

Static tags are those tags that you have generated by means of the OPC-tag-editor. You can use the browser of an OPC client to select certain tags from the list of OPC-tags that you have defined here.

Dynamic tags are those tags that you have generated directly on an OPC client. If you are not selecting from a list of existing tags on an OPC client by means of the browser but you enter the name of the controller and the link directly into a field (separated by a slash) then the OPC-Server generates a this tag dynamically.

Example

You have entered "Heater/MW0" directly into an OPC client. The OPC-Server will first check whether a static tag by the name "MW0" was previously defined in the controller "Heater". If it can not locate a tag named "MW0" then the OPC-Server checks whether the term "MW0" represents a valid link to a CPU. In this example this is true. The OPC-Server will now dynamically generate a tag by the name of "Heater/MW0" and that is linked to "MW0" in the PLC referred to as "Heater". The data type results from the syntax "word", i.e. unsigned 16bit number in this case. The switch "DynamicTags" determines whether the dynamically generated tag is "read only" or "read write".
Simulation

You can instruct OPC-Server to simulate this PLC by means of the switch "simulation". This can assist you when you do not have access to a PLC for test purposes, for example to test your visualization. This is a selection field. Press any key to open the selection list. When defining static tags, you can define an initial value for each tag that is used by the simulation.

When an OPC client accesses a tag that is located in a simulated PLC then the initial value is returned that was configured for the tag when the project was started. If the OPC client writes a value into the tag than the OPC-Server saves the new value and returns this to the client when this reads the value again. If the client is terminated and started the OPC-Server will again return the initial value.

If you should start several OPC clients and link them to the same tag then all OPC clients will receive the same value for that tag, exactly in the same manner as if the PLC was not being simulated. Every OPC client has the permission to write and all OPC clients receive the entered value as the value that is read. The OPC-Server stores the last value that was written as long as an OPC client requests the tag.

You can only configure an initial value for the simulation for static tags. If the OPC client should be using dynamic tags then the value is set to 0 for numeric tags and to "x" for strings.

If you have configured static tags that overlap then this does not have any effect in the simulation mode.

Example

You are configuring the tags:

TestSPS/Wert1  MB10
TestSPS/Wert2  MW10

When an OPC client writes a value into MB10 only the OPC clients for the tag "Wert1" are notified of the change in the value and not those for the tag "Wert2".
Max. clipping between 2 requests

The Read/Write over TCP protocol tries to combine requests required for the OPC client.

**Example 1:**
Your OPC client requires the MB0 and the MB1. In this case the protocol will request two bytes starting with MB0 so that two tags are served with one read access.

**Example 2:**
Your OPC client requires the MB0 and the MB1250. Normally in this case it is not convenient to combine the requests.

By means of this option you may set the distance between two required variables from the PLC so that the protocol driver still combines them.

The presetting is 30.
S7-PG over ISO on TCP/IP

Select ISO on TCP/IP network in the project view to display the respective data.

**File name**
This entry specifies the file name of the file where the data is saved. This name cannot be changed. The file name is derived from the name of the network in the project view.

**Local IP-address**
If your computer is equipped with more than one network adapter then you must enter the IP-address of the adapter to which this Read/Write-Network applies in this location.
If your computer is equipped with a single network adapter you can enter the IP-address 0.0.0.0. If you specify this address the first network adapter that is detected will be used automatically.

ISO on TCP/IP controller

Select the controller of a ISO on TCP/IP network to display the respective data.

**Filename**
This entry specifies the file name of the file where the parameters of the controller are saved. This name cannot be changed. The file name is derived from the name of the controller in the project view.

**Slot no.**
Type the number of the CPU slot that you want to call.

**Remote IP address**
Here you must specify the IP-address of the CPU. Make sure that the IP-address of the CPU and the IP-address of the PC are located in the same network (network-mask) when you assign addresses. Alternatively here you may enter a name. The OPC-Server supports name resolution like e.g. MyPLC.DynDNS.org.
**Dynamic tags**

This parameter determines whether the controller will support dynamic tags or whether it will only use preset tags.

This is a selection field. Press a key on the keyboard to open a list for the selection.

Static tags are those tags that you have generated by means of the OPC-tag-editor. You can use the browser of an OPC client to select certain tags from the list of OPC-tags that you have defined here.

Dynamic tags are those tags that you have generated directly on an OPC client. If you are not selecting from a list of existing tags on an OPC client by means of the browser but you enter the name of the controller and the link directly into a field (separated by a slash) then the OPC-Server generates a this tag dynamically.

**Example**

You have entered "Heater/MW0" directly into an OPC client. The OPC-Server will first check whether a static tag by the name "MW0" was previously defined in the controller "Heater". If it can not locate a tag named "MW0" then the OPC-Server checks whether the term "MW0" represents a valid link to a CPU. In this example this is true. The OPC-Server will now dynamically generate a tag by the name of "Heater/MW0" and that is linked to "MW0" in the PLC referred to as "Heater". The data type results from the syntax "word", i.e. unsigned 16bit number in this case. The switch "DynamicTags" determines whether the dynamically generated tag is "read only" or "read write".

**Cycle time**

This parameter sets the cycle time within the OPC-Server communicates with the control. The default value is 20ms. You may adjust this value within the range 20-1000ms.
Simulation

You can instruct OPC-Server to simulate this PLC by means of the switch "simulation". This can assist you when you do not have access to a PLC for test purposes, for example to test your visualization.

This is a selection field. Press any key to open the selection list.

When defining static tags, you can define an initial value for each tag that is used by the simulation.

When an OPC client accesses a tag that is located in a simulated PLC then the initial value is returned that was configured for the tag when the project was started. If the OPC client writes a value into the tag than the OPC-Server saves the new value and returns this to the client when this reads the value again. If the client is terminated and started the OPC-Server will again return the initial value.

If you should start several OPC clients and link them to the same tag then all OPC clients will receive the same value for that tag, exactly in the same manner as if the PLC was not being simulated. Every OPC client has the permission to write and all OPC clients receive the entered value as the value that is read. The OPC-Server stores the last value that was written as long as an OPC client requests the tag.

You can only configure an initial value for the simulation for static tags. If the OPC client should be using dynamic tags then the value is set to 0 for numeric tags and to "x" for strings.

If you have configured static tags that overlap then this does not have any effect in the simulation mode.

Example

You are configuring the tags:

TestSPS/Wert1 MB10
TestSPS/Wert2 MW10

When an OPC client writes a value into MB10 only the OPC clients for the tag "Wert1" are notified of the change in the value and not those for the tag "Wert2".

Ping enabled

Select here, whether you will perform a ping before the connection is established. If you choose "1" the connection is tested before by means of the ping function, whether the participant may be reached. If no ping is required choose "0".

Default value: "1"

Without a previous ping query modern operating systems will block the connection establishment.

Max. PDU size

This parameter fixes the maximum package size in bytes.

Press any key to open the selection list.

Three package sizes may be selected: 240 bytes, 480 bytes and 960 bytes. 960 bytes are default.

Older CPUs support only a PDU size of 240 bytes.
List of tags

The list of tags that was defined for this controller is located just below the configuration settings for the controller.

Tag
Contains the name of the tag. This name must be unique within the controller (however, the same name can be used without restriction in other controllers). A warning is issued if the name is not valid.
The maximum length of the name of the tag is limited to 32 characters.
The name of the Tag mustn't contain comma and hyphen!

Linking
Contains the allocation to a memory area within the controller. A warning is issued if the link is not valid. The appendix contains a list of all the links that are acceptable.

Access rights
Specifies a valid access type.
RO = read only
RW = read write

Simulation
Here you can define an initial value for the tag that is used by the simulation mode. Depending on the data type of the tag, you must enter a number or a text. When you are entering floating point numbers you must remember to enter a "comma" instead of a decimal point. The character "E" denotes exponential values. The text for strings is entered directly. If you were to enter values for an array you must separate the different values by the character "|".

Examples

<table>
<thead>
<tr>
<th>Data type</th>
<th>Entry</th>
</tr>
</thead>
<tbody>
<tr>
<td>Fixed point</td>
<td>12 or +12 or -12 or as array 12</td>
</tr>
<tr>
<td>Floating point</td>
<td>12 or 12,0 or +12,0 or +12,345E-5 or -12,345-E23</td>
</tr>
<tr>
<td>String</td>
<td>It is a nice day today</td>
</tr>
</tbody>
</table>

Commentary
You can enter a comment of maximum 255 characters in this column.
Sorting the tags on the display

Sorting
If you double-click the heading of a column, the list of tags is sorted in the order of the selected column.

Deleting tags

Deleting
Select a number of tags by means of the mouse and click the [Delete] button on the tool bar.
The tags you have selected are removed (after confirmation) from the list.

Using MS Excel to configure the tag list

Tag list
The tag list is saved as a CSV-file in the directory `\INI` below the installation directory. The file name is created from the name of the controller and the extension `.csv`.
You can also configure this list by means of MS Excel.
For this purpose you must start MS Excel and select **File > Open**. In the following dialog box you select the file type text file (`*.csv`). Now you must select the CSV-file that you wish to use in your project.

Attention!
Before opening a CSV-file of the project by means of MS Excel you must make sure that you have terminated the OPC-editor. If not, you could be facing conflicts due to the fact that you are operating on the same file from two different programs.
Displaying the online value of a tag

Right-click a tag by means of the mouse.
A context menu with the heading "Online value test" is displayed.

Online test

<table>
<thead>
<tr>
<th>Tag</th>
<th>Ehitzer/T1C30</th>
</tr>
</thead>
<tbody>
<tr>
<td>Destination</td>
<td>DB10.W63</td>
</tr>
<tr>
<td>Access right</td>
<td>RW</td>
</tr>
</tbody>
</table>

The upper half of the menu shows the link for the current tag.
The bottom half displays (provided that a controller has been connected, that the OPC-Server is active and that the respective tag is available from the OPC-Server) the online-value of the tag.

Value
Displays the online-value. The values of an array are separated by the symbol "|".

Quality
Indicates the "quality" of the value. Here the OPC-Server returns information on how you can assess the value that is being displayed as well as any relevant information on why a value can not be displayed.

Time stamp
Indicates the time when the value that is being displayed was read. If this field contains "not valid" this means that the value was read for the first time from the controller.
List of quality indicators

<table>
<thead>
<tr>
<th>Text</th>
<th>Significance</th>
</tr>
</thead>
<tbody>
<tr>
<td>Good (non-specific)</td>
<td>The value is good, no other details are available.</td>
</tr>
<tr>
<td>Good (local override)</td>
<td>The value was disabled. This typically means that the input was disconnected and that a manually entered value was used.</td>
</tr>
<tr>
<td>Bad (non-specific)</td>
<td>The value is bad, but the reason is not available.</td>
</tr>
<tr>
<td>Bad (configuration error)</td>
<td>This indicates that a server-related problem exists in the configuration. The respective tag could have been removed from the configuration.</td>
</tr>
<tr>
<td>Bad (not connected)</td>
<td>The input should have a logical link, but this does not exist. This could mean that a value is currently not available, for instance if the source did not supply a value.</td>
</tr>
<tr>
<td>Bad (device failure)</td>
<td>A device error was detected.</td>
</tr>
<tr>
<td>Bad (sensor failure)</td>
<td>A sensor error was detected.</td>
</tr>
<tr>
<td>Bad (last known value)</td>
<td>Communications was interrupted, however, the most recent value is still available for use.</td>
</tr>
<tr>
<td>Bad (comm failure)</td>
<td>Communications was interrupted, however, the most recent value is not available for use.</td>
</tr>
<tr>
<td>Bad (out of service)</td>
<td>The module is not accessible or it is blocked by some other mechanism.</td>
</tr>
<tr>
<td>Uncertain (non-specific)</td>
<td>The value is uncertain, however, the reason is not available.</td>
</tr>
<tr>
<td>Uncertain (last usable value)</td>
<td>The returned value should be considered as being &quot;dead&quot;. Please remember that this does not refer to a bad value. The error is caused by the inability of an external source to write to the value within an acceptable time period.</td>
</tr>
<tr>
<td>Uncertain (sensor not accurate)</td>
<td>The value has either exceeded one of the limits or the internal diagnostics have detected that the sensor was not calibrated correctly.</td>
</tr>
<tr>
<td>Uncertain (engineering units)</td>
<td>The returned value is located outside the limits that were defined for this parameter.</td>
</tr>
<tr>
<td>Uncertain (sub-normal)</td>
<td>The value was derived from multiple sources and it has less than the required number of good sources.</td>
</tr>
</tbody>
</table>
Example of an OPC-project

Define a new project and a network

Start the OPC-editor

This displays the project view. The file at the root of the new OPC-project has been selected and the respective properties are displayed in the panel on the right. Enter the settings you require.

Select File
> Project new

Select Edit
> Add network

You could also right-click the OPC-project to reach this menu via the context menu.

The dialog box that allows you to define a network is displayed.

Enter "MPINetz1" as the name.
Select "MPI over COMPort" as network type.
Click [OK].

The dialog box is closed, in the project view the new network is displayed below the OPC-project.

Select the network "MPINetz1"

Details of the network are displayed in the panel on the right.
Enter the required parameters.
Adding a controller

Select Edit > Add controller

You can also right-click the OPC-network to display the context menu. If you do not have access to the menu item "Add controller" then the project view does not display a network but a different type of entry, e.g. the OPC-project itself. You can only add networks to an OPC-project, but you can add controllers to an OPC-network.

The dialog box for the definition of a controller will be displayed.
Enter "Controller1" as the name.
Click [OK].

The dialog box is closed and in the project view the new controller is displayed below the selected network.

Select the controller "Controller1"

Enter the required settings.

Add the following tags to the list:
TIC98 MW10 RO
TIC99 MB0 RW
Select File > Save As

If you should select File > Save the OPC-editor will detect that this is a new project that has not yet been saved and it will prompt you to use "Save As" to enable you to select a directory for the project.

Select File > Save As

Select the directory C:\Program Files\OPC\INI as the target directory. Select [OK].

You will now have to confirm that you wish to save the data. Confirm by means of [OK].

Once the data has been saved a message is displayed that can either state that the project has been saved successfully or that an error has occurred.

If you wish to view the errors that have occurred you can click at Tools > Display Write Errors.
OPC-Server reconfiguration

Select Tools
> OPC-Server reconfiguration

If you are connected to an OPC-Server that can access the controllers you invoke the OPC-Server to read the new data. The dialog box for the reconfiguration of the local OPC-Server is displayed.

Select [Reconfigure].

Once the reconfiguration has been completed successfully the new OPC-project becomes available.

Close the dialog box.

Select controller "Controller1".

Select "TIC99".
Click the right mouse key and select "Display online value".
The dialog box for the online display is opened.

If everything has been configured correctly and if the hardware was connected properly the value of the tag including quality and time stamp are displayed.

Select [OK] to close the dialog box.
Select File > Exit, this terminates the OPC-editor.
Appendix

The syntax of the links

Syntax

Here follows a description of the syntax that applies to the link between an OPC-tag and a data item.

The following syntax is accepted:

DB<No>,<Type><Address>{,<Quantity>}
DX<No>,<Type><Address>{,<Quantity>}
<Object><Type><Address>{,<Quantity>}

DB     Represents a data block
DX     Represents an extended data block
<No>   is the number of the DB
<Object> The following objects exist: E,A,M,T, Z, S, P
         In English notation these are: I,Q,M,T,C
<Type> The Type specifies the type of data. This is converted to the required data type by the OPC-Server.
         The following S7 data types are available:
         X  one bit
         B  byte (unsigned)
         W  word (unsigned)
         D  double word (unsigned)
         CHAR  character (signed)
         INT  word (signed)
         DINT  double word (signed)
         REAL  floating point
         STRING  character sequence, the length of the string must be specified.
         S7STRING  character sequence in the S7 format, the length of the string must be specified.

<Address> Address, e.g. MD5 or
         Address, e.g. EX1.1 or
         Address, e.g. DB10,STRING4,20

<Quantity> Number of variables of the same type that will be accessed at the address specified in the parameter. This number is not valid for data type X.
The syntax above provides the option for a number of links. The following table shows one example of every possible link:

**Link to a data block**  If you wish to create a link to an extended data block you must use "DX" instead of "DB":

- DB1,X2.3
- DB1,B2
- DB1,B2,3
- DB1,W2
- DB1,W2,3
- DB1,D2
- DB1,D2,3
- DB1,CHAR2
- DB1,CHAR2,3
- DB1,INT2
- DB1,INT2,3
- DB1,DINT2
- DB1,DINT2,3
- DB1,REAL2
- DB1,REAL2,3
- DB1,STRING2
- DB1,S7STRING2,3
Links to inputs

In English notation you can use the "I" for "input" instead of the "E" as the first character.

EX2.3
EB2
EB2,3
EW2
EW2,3
ED2
ED2,3
ECHAR2
ECHAR2,3
EINT2
EINT2,3
EDINT2
EDINT2,3
EREAL2
EREAL2,3
ESTRING2,3
ES7STRING2,3

Links to outputs

In English notation you can use the "Q" for "output" instead of the "A" as the first character.

AX2.3
AB2
AB2,3
AW2
AW2,3
AD2
AD2,3
ACHAR2
ACHAR2,3
AINT2
AINT2,3
ADINT2
ADINT2,3
AREAL2
AREAL2,3
ASTRING2,3
AS7STRING2,3
Links to flags

In English notation you can use the "F" for "flag" instead of the "M" as the first character. If you are creating a link to a special flag you would use "S" for the first character instead of the "M".

- MX2.3
- MB2
- MB2,3
- MW2
- MW2,3
- MD2
- MD2,3
- MCHAR2
- MCHAR2,3
- MINT2
- MINT2,3
- MDINT2
- MDINT2,3
- MREAL2
- MREAL2,3
- MSTRING2,3
- MS7STRING2,3

Links to timers

A timer can only be read. If you want to allow a timer to be set via, e.g. visualization then you must specify the planned value in a data block. Your control program must then read the starting value for the timer from this data block.

- T1
- T1,2

Links to counters

In English notation you can use the "C" for "counter" instead of the "Z" as the first character.

- Z1
- Z1,2
Index

B
Basics 1

C
Client computer 15
Component Services 9
Configuration interface 43
  Detailed view 44

D
DCOM configuration 15
  Default authentication level 17
  Default impersonation level 17

E
Edit menu 33
  add network 33
  add PLC 34
  delete network 33
  delete PLC 34
Example 62

F
File menu 31
  Firewall settings 21, 23
  Function specifications 3

H
Help menu 41
  File information 42
  OS-version 41

I
ISO on TCP/IP controller
  Dynamic tags 56
  Plug-in location number 55
  Remote IP-address 55
  Simulation 57
ISO on TCP/IP network 55
  Display local IP-address 55

L
Licensing 18
Links
  Counters 71
  Data blocks 69
  Flags 71
  Inputs 70
  Outputs 70
  Syntax 68
  Timers 71
List of quality indicators 61
List of tags
  Deleting 59
  Online-value 60
  Quality 60
  Sorting 59
  Time stamp 60
  Using MS Excel to configure the tag list 59

M
MPI-controller 48
  Dynamic tags 48
  Example 48
  MPI-slave number 48
  Simulation 49
MPI-network 2
  Baudrate 47
  COM-Port 47
  Cycle time 47
  MPI-slave number 47

O
OPC-editor 30
  Directory 30
  Operating system 6

R
Read/Write over TCP/IP-controller
  Dynamic tags 52
  Local port in read mode 51
  Local port in write mode 51
  Remote IP-address 51
  Remote port read 51
  Remote port write 51
Simulation 53
Type of controller 50
Read/Write over TCP/IP-network 50
Display local IP-address 50

S
Security Policy 8
Server computer 15
Setup 7
  OPC-editor 7
  OPC-server 7

T
Tags 3
  Dynamic tags 4
  Example 5
  Static tags 3
  Symbolic link 3
TCP/IP-network 2
Tools menu 35
  Eventlog display 37
  Font size 36
  Language 36
  Log files 37
  Options 40
  Read error 35
  Reconfiguration 38
  Services 37
  Settle project directory 39
  User administration 37
  Write error 36